<!doctype html>
<html lang="en-US" class="no-js">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://www.gmpg.org/xfn/11">

<title>Victim&#039;s name released from Monday&#039;s fatal Mason City structure fire | KGLO News</title>
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Victim&#039;s name released from Monday&#039;s fatal Mason City structure fire | KGLO News" />
<meta property="og:description" content="MASON CITY &#8212; Mason City fire officials have released the name of the victim of a fatal" />
<meta property="og:url" content="https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/" />
<meta property="og:site_name" content="KGLO News" />
<meta property="article:publisher" content="https://www.facebook.com/kglonews" />
<meta property="article:published_time" content="2021-02-26T17:02:26+00:00" />
<meta property="article:modified_time" content="2021-02-26T17:29:05+00:00" />
<meta property="og:image" content="https://www.kglonews.com/wp-content/uploads/2018/05/mcfd-logo-e1571232763595.jpg" />
<meta property="og:image:width" content="300" />
<meta property="og:image:height" content="300" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@kglonews" />
<meta name="twitter:site" content="@kglonews" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="KGLO News">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="1 minute">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.kglonews.com/#organization","name":"KGLO News","url":"https://www.kglonews.com/","sameAs":["https://www.facebook.com/kglonews","https://twitter.com/kglonews"],"logo":{"@type":"ImageObject","@id":"https://www.kglonews.com/#logo","inLanguage":"en-US","url":"https://www.kglonews.com/wp-content/uploads/2017/12/KGLO-NEWS-LOGO-2-1.png","width":7732,"height":3876,"caption":"KGLO News"},"image":{"@id":"https://www.kglonews.com/#logo"}},{"@type":"WebSite","@id":"https://www.kglonews.com/#website","url":"https://www.kglonews.com/","name":"KGLO News","description":"Your Hometown News Station","publisher":{"@id":"https://www.kglonews.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.kglonews.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/#primaryimage","inLanguage":"en-US","url":"https://www.kglonews.com/wp-content/uploads/2018/05/mcfd-logo-e1571232763595.jpg","width":300,"height":300},{"@type":"WebPage","@id":"https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/#webpage","url":"https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/","name":"Victim's name released from Monday's fatal Mason City structure fire | KGLO News","isPartOf":{"@id":"https://www.kglonews.com/#website"},"primaryImageOfPage":{"@id":"https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/#primaryimage"},"datePublished":"2021-02-26T17:02:26+00:00","dateModified":"2021-02-26T17:29:05+00:00","breadcrumb":{"@id":"https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/"]}]},{"@type":"BreadcrumbList","@id":"https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.kglonews.com/","url":"https://www.kglonews.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/","url":"https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/","name":"Victim&#8217;s name released from Monday&#8217;s fatal Mason City structure fire"}}]},{"@type":"Article","@id":"https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/#article","isPartOf":{"@id":"https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/#webpage"},"author":{"@id":"https://www.kglonews.com/#/schema/person/236c39229aad47696b579211ff9e6524"},"headline":"Victim&#8217;s name released from Monday&#8217;s fatal Mason City structure fire","datePublished":"2021-02-26T17:02:26+00:00","dateModified":"2021-02-26T17:29:05+00:00","mainEntityOfPage":{"@id":"https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/#webpage"},"publisher":{"@id":"https://www.kglonews.com/#organization"},"image":{"@id":"https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/#primaryimage"},"articleSection":"Breaking News,Local News","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.kglonews.com/#/schema/person/236c39229aad47696b579211ff9e6524","name":"KGLO News","image":{"@type":"ImageObject","@id":"https://www.kglonews.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/1e05c5c7fa298f22861ca6623ed9244d?s=96&d=mm&r=g","caption":"KGLO News"}}]}</script>

<link rel='dns-prefetch' href='//embed.air.tv' />
<link rel='dns-prefetch' href='//pr.realvu.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="KGLO News &raquo; Feed" href="https://www.kglonews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="KGLO News &raquo; Comments Feed" href="https://www.kglonews.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="KGLO News &raquo; iCal Feed" href="https://www.kglonews.com/events/?ical=1" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.kglonews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.kglonews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='fvp-frontend-css' href='https://www.kglonews.com/wp-content/plugins/featured-video-plus/styles/frontend.css?ver=2.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css' href='https://fonts.googleapis.com/css?family=Poppins%3A500%2C700%7COswald%3A700&#038;ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='blacklab-stylesheet-css' href='https://www.kglonews.com/wp-content/themes/blacklab/assets/css/public/styles.css?ver=3.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='blacklab-theme-color-stylesheet-css' href='https://www.kglonews.com/wp-content/themes/blacklab/assets/css/public/theme-colors/orange.css?ver=5.6.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.kglonews.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.kglonews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' defer src='https://www.kglonews.com/wp-content/plugins/featured-video-plus/js/jquery.fitvids.min.js?ver=master-2015-08' id='jquery.fitvids-js'></script>
<script type='text/javascript' id='fvp-frontend-js-extra'>
/* <![CDATA[ */
var fvpdata = {"ajaxurl":"https:\/\/www.kglonews.com\/wp-admin\/admin-ajax.php","nonce":"87a9981445","fitvids":"1","dynamic":"","overlay":"","opacity":"0.75","color":"b","width":"640"};
/* ]]> */
</script>
<script type='text/javascript' defer src='https://www.kglonews.com/wp-content/plugins/featured-video-plus/js/frontend.min.js?ver=2.3.3' id='fvp-frontend-js'></script>
<script async="async" data-cfasync=false type='text/javascript' src='https://embed.air.tv/v1/twoview_bootstrap.js?organization=C6_LZjhKTcOyKY_5w72rWw&#038;ver=5.6.1' id='airTV-js'></script>
<link rel="https://api.w.org/" href="https://www.kglonews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.kglonews.com/wp-json/wp/v2/posts/51773" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.kglonews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.kglonews.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.6.1" />
<link rel='shortlink' href='https://www.kglonews.com/?p=51773' />
<link rel="alternate" type="application/json+oembed" href="https://www.kglonews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kglonews.com%2Fvictims-name-released-from-mondays-fatal-mason-city-structure-fire%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.kglonews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kglonews.com%2Fvictims-name-released-from-mondays-fatal-mason-city-structure-fire%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.kglonews.com"><link rel="https://theeventscalendar.com/" href="https://www.kglonews.com/wp-json/tribe/events/v1/" /> <style type="text/css">.pp-podcast {opacity: 0;}</style>
<link rel="icon" href="https://www.kglonews.com/wp-content/uploads/2017/12/cropped-KGLONews_Icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.kglonews.com/wp-content/uploads/2017/12/cropped-KGLONews_Icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.kglonews.com/wp-content/uploads/2017/12/cropped-KGLONews_Icon-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.kglonews.com/wp-content/uploads/2017/12/cropped-KGLONews_Icon-270x270.png" />
<style id="kirki-inline-styles"></style>
<script>
		window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;

	  				ga('create', 'UA-75631910-9', 'auto', 'stationTracker');
	  		  				ga('create', 'UA-69031038-1', 'auto', 'globalTracker');
	  	
	  				ga('stationTracker.require', 'eventTracker');
			ga('stationTracker.require', 'outboundLinkTracker');
			/*ga('stationTracker.require', 'cleanUrlTracker', {
				stripQuery: true,
				queryParamsWhitelist: ['s', 'id', 'd', 'cat']
			});*/
	  		  				ga('globalTracker.require', 'eventTracker');
			ga('globalTracker.require', 'outboundLinkTracker');
			/*ga('globalTracker.require', 'cleanUrlTracker', {
			  	stripQuery: true,
			  	queryParamsWhitelist: ['s', 'id', 'd', 'cat']
			});*/
	  	
	  				ga('stationTracker.send', 'pageview');
	  		  				ga('globalTracker.send', 'pageview');
	  		</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>
<script async src='https://www.kglonews.com/wp-content/themes/blacklab/assets/js/libraries/autotrack.js'></script>
</head>
<body class="post-template-default single single-post postid-51773 single-format-standard nav-background-light small-logo tribe-no-js tribe-bar-is-disabled tribe-theme-blacklab alert-active custom-bg">
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-K53S345"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-K53S345');</script>
<div class="uk-offcanvas-content">
<header class="small-logo main-header">
<div class="uk-width-1-1" uk-sticky>
<nav class="main-navbar uk-flex nav-background-light" navbar>
<ul class="uk-navbar-nav uk-width-1-1 uk-child-width-auto uk-grid">
<li class="nav-button uk-padding-remove uk-margin-remove uk-visible@m uk-flex uk-flex-center">
<a uk-icon="menu" alt="Menu" uk-toggle="target: #offcanvas-nav" ga-on="click" ga-event-category="Menu" ga-event-label="Hamburger Button" ga-event-action="click" class="menu uk-height-1-1"></a>
</li>
<li class="nav-button uk-padding-remove uk-margin-remove uk-width-1-1 uk-width-auto@m uk-flex uk-flex-center station-logo">
<a href="https://www.kglonews.com" class="uk-padding-remove" ga-on="click" ga-event-category="Menu" ga-event-label="Station Logo" ga-event-action="click">
<img id="station-logo" src="https://dl.airtable.com/.attachments/b1bee7a3216d76a06bbcd24b19c4ceba/5f5b591b/KGLO-NEWS-LOGO-2.png" draggable="false" />
</a>
</li>
<li class="nav-button uk-width-expand uk-height-1-1 uk-padding-remove uk-margin-remove remove-border uk-visible@m main-nav"><ul class="uk-navbar-nav main-navbar-nav four primary-nav uk-width-expand uk-height-1-1 uk-margin-remove uk-padding-remove uk-grid"><li id="menu-item-18990" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children uk-parent nav-button uk-padding-remove uk-margin-remove uk-visible@m uk-flex uk-flex-center uk-width-expand"><a href="https://www.kglonews.com/category/local-news/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="Local News" class="uk-width-1-1">Local News</a>
<div class="uk-navbar-dropdown uk-grid uk-margin-remove uk-padding-remove" uk-dropdown="remaintime: 0; boundary: #menu-item-18990; boundary-align: true; pos: bottom-left;"><ul class="dropdown-nav-menu uk-nav uk-navbar-dropdown-nav" uk-list>
<li id="menu-item-25116" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.kglonews.com/category/audio-archives/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="Audio Archives" class="uk-width-1-1">Audio Archives</a></li>
<li id="menu-item-25130" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.kglonews.com/category/ask-the-mayor/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="Ask the Mayor" class="uk-width-1-1">Ask the Mayor</a></li>
</ul>
</li>
<li id="menu-item-418" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children uk-parent nav-button uk-padding-remove uk-margin-remove uk-visible@m uk-flex uk-flex-center uk-width-expand"><a href="https://www.kglonews.com/kglo-krib-sports/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="Sports Broadcasts" class="uk-width-1-1">Sports Broadcasts</a>
<div class="uk-navbar-dropdown uk-grid uk-margin-remove uk-padding-remove" uk-dropdown="remaintime: 0; boundary: #menu-item-418; boundary-align: true; pos: bottom-left;"><ul class="dropdown-nav-menu uk-nav uk-navbar-dropdown-nav" uk-list>
<li id="menu-item-419" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.kglonews.com/kglo-krib-sports-broadcast-calendar/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="KGLO &#038; KRIB Sports Broadcast Calendar" class="uk-width-1-1">KGLO &#038; KRIB Sports Broadcast Calendar</a></li>
<li id="menu-item-48955" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.kglonews.com/2020-21-clear-lake-lions-winter-sports-on-krib/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="2020-21 Clear Lake Winter Sports on KRIB" class="uk-width-1-1">2020-21 Clear Lake Winter Sports on KRIB</a></li>
<li id="menu-item-47961" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.kglonews.com/2020-21-mohawk-hockey-on-krib/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="2020-21 Mohawk Hockey on KRIB" class="uk-width-1-1">2020-21 Mohawk Hockey on KRIB</a></li>
<li id="menu-item-46119" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.kglonews.com/2020-clear-lake-lions-football/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="2020 Clear Lake Lions Football on KRIB" class="uk-width-1-1">2020 Clear Lake Lions Football on KRIB</a></li>
<li id="menu-item-46247" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.kglonews.com/2020-mason-city-high-football-on-am-1300-kglo/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="2020 Mason City High Football on AM-1300 KGLO" class="uk-width-1-1">2020 Mason City High Football on AM-1300 KGLO</a></li>
<li id="menu-item-46246" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.kglonews.com/2020-newman-football-on-93-9-kia-fm/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="2020 Newman Football on 93.9 KIA-FM" class="uk-width-1-1">2020 Newman Football on 93.9 KIA-FM</a></li>
<li id="menu-item-46120" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.kglonews.com/local-sports-broadcast-archives/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="Local Sports Broadcast Archives" class="uk-width-1-1">Local Sports Broadcast Archives</a></li>
<li id="menu-item-46893" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.kglonews.com/watch-clear-lake-lions-sports/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="Watch Lions Sports" class="uk-width-1-1">Watch Lions Sports</a></li>
</ul>
</li>
<li id="menu-item-48363" class="menu-item menu-item-type-post_type menu-item-object-page nav-button uk-padding-remove uk-margin-remove uk-visible@m uk-flex uk-flex-center uk-width-expand"><a href="https://www.kglonews.com/contact/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="Contact/Social Media" class="uk-width-1-1">Contact/Social Media</a></li>
<li id="menu-item-19488" class="menu-item menu-item-type-custom menu-item-object-custom nav-button uk-padding-remove uk-margin-remove uk-visible@m uk-flex uk-flex-center uk-width-expand"><a href="https://www.kglonews.com/closings/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="Closings" class="uk-width-1-1">Closings</a></li>
<li id="menu-item-406" class="menu-item menu-item-type-post_type menu-item-object-page nav-button uk-padding-remove uk-margin-remove uk-visible@m uk-flex uk-flex-center uk-width-expand"><a href="https://www.kglonews.com/kglo-news-team/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="News Team" class="uk-width-1-1">News Team</a></li>
<li id="menu-item-37678" class="menu-item menu-item-type-custom menu-item-object-custom nav-button uk-padding-remove uk-margin-remove uk-visible@m uk-flex uk-flex-center uk-width-expand"><a href="https://sos.iowa.gov/elections/voterreg/pollingplace/search.aspx" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="Find Your Polling Place" class="uk-width-1-1">Find Your Polling Place</a></li>
<li id="menu-item-141" class="menu-item menu-item-type-post_type menu-item-object-page nav-button uk-padding-remove uk-margin-remove uk-visible@m uk-flex uk-flex-center uk-width-expand"><a href="https://www.kglonews.com/contact/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="Contact" class="uk-width-1-1">Contact</a></li>
<li id="menu-item-145" class="menu-item menu-item-type-post_type menu-item-object-page nav-button uk-padding-remove uk-margin-remove uk-visible@m uk-flex uk-flex-center uk-width-expand"><a href="https://www.kglonews.com/weather-forecast/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="Weather" class="uk-width-1-1">Weather</a></li>
<li id="menu-item-27506" class="menu-item menu-item-type-custom menu-item-object-custom nav-button uk-padding-remove uk-margin-remove uk-visible@m uk-flex uk-flex-center uk-width-expand"><a href="http://alphamediacares.com" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="Alpha Media Cares &#8211; Donate" class="uk-width-1-1">Alpha Media Cares &#8211; Donate</a></li>
<li id="menu-item-18989" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-button uk-padding-remove uk-margin-remove uk-visible@m uk-flex uk-flex-center uk-width-expand"><a href="https://www.kglonews.com/category/local-sports/" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="Local Sports" class="uk-width-1-1">Local Sports</a></li>
</ul></li> <li class="nav-button uk-visible@m uk-margin-remove uk-padding-remove social four uk-width-1-6 search uk-grid uk-visible@l">
<ul class="uk-grid uk-width-expand uk-child-width-expand uk-margin-remove uk-padding-remove">
<li class="nav-button uk-padding-remove uk-margin-remove uk-visible@m uk-flex uk-flex-center search-dropdown">
<a class="uk-flex uk-flex-center uk-flex-middle uk-width-1-1 uk-icon" href="" ga-on="click" ga-event-category="Menu" ga-event-label="Search - Icon" ga-event-action="click" uk-icon="icon: search"></a>
<div class="uk-navbar-dropdown" uk-dropdown="pos: bottom-left; offset: 0;">
<div class="uk-padding-small uk-padding-remove-vertical">
<div class="uk-grid-small uk-flex-middle" uk-grid>
<div class="uk-width-expand">
<form class="uk-search uk-search-navbar uk-width-1-1" role="search" action="https://www.kglonews.com/" method="get">
<input class="uk-search-input" type="search" name="s" placeholder="Search..." autofocus />
</form>
</div>
<div class="uk-width-auto">
<a class="uk-navbar-dropdown-close" href="#" ga-on="click" ga-event-category="Menu" ga-event-label="Search - Close Button" ga-event-action="click" uk-close></a>
</div>
</div>
</div>
</div>
</li>
<li class="nav-button uk-padding-remove uk-margin-remove uk-visible@m uk-flex uk-flex-center social-container">
<a class="uk-flex uk-flex-center uk-flex-middle uk-width-1-1" uk-icon="social"></a>
<div class="uk-navbar-dropdown uk-margin-remove uk-padding-remove" uk-dropdown="pos: bottom-left; offset: 0;">
<ul class="uk-nav uk-navbar-dropdown-nav" uk-list>
<li class="uk-padding-remove-left">
<a class="text-medium" href="https://www.facebook.com/kglonews" target="_blank" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="facebook">
<div class="uk-flex uk-flex-middle">
<span class="uk-margin-small-right uk-icon" uk-icon="icon:facebook"></span>
<span>
Facebook </span>
</div>
</a>
</li>
<li class="uk-padding-remove-left">
<a class="text-medium" href="https://www.twitter.com/kglonews" target="_blank" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="twitter">
<div class="uk-flex uk-flex-middle">
<span class="uk-margin-small-right uk-icon" uk-icon="icon:twitter"></span>
<span>
Twitter </span>
</div>
</a>
</li>
<li class="uk-padding-remove-left">
<a class="text-medium" href="https://soundcloud.com/user-637382429" target="_blank" ga-on="click" ga-event-category="Menu" ga-event-action="click" ga-event-label="soundcloud">
<div class="uk-flex uk-flex-middle">
<span class="uk-margin-small-right uk-icon" uk-icon="icon:soundcloud"></span>
<span>
Soundcloud </span>
</div>
</a>
</li>
</ul>
</div>
</li>
</ul>
</li>

<li class="nav-button uk-width-expand uk-padding-remove uk-margin-remove nav-player uk-flex uk-flex-middle">
<ul class="uk-grid nav-player uk-width-1-1 uk-margin-remove uk-padding-remove uk-height-1-1">

<li class="nav-button small-logo nav-button audio-player uk-grid uk-width-1-1 uk-position-relative uk-padding-remove-left uk-margin-remove-left">

<div class="player-container uk-width-1-1 uk-grid uk-padding-remove">
<div class="play-btn-container uk-margin-remove uk-padding-remove" style="background-image: url('https://www.kglonews.com/wp-content/themes/blacklab/assets/img/audio/bullseye-light.jpg');">
<div class="play-btn-outer-circle uk-position-relative uk-height-1-1 uk-padding-remove uk-margin-remove">
<a href="https://www.alphamediaplayer.com/kglonews" class="play-btn uk-position-center uk-padding-remove uk-margin-remove" target="_blank" ga-on="click" ga-event-category="Menu" ga-event-label="Player Link" ga-event-action="click"></a>
</div>
</div>

<div class="uk-width-expand current-song uk-margin-remove">
<p class="current-song-credits uk-overflow-hidden uk-position-relative">
<a href="https://www.kglonews.com/recently-played" id="songTitle" class="title uk-overflow-hidden uk-position-absolute" ga-on="click" ga-event-category="Menu" ga-event-label="Current Song Title" ga-event-action="click"></a>
<span id="songArtist" class="artist"></span>
</p>
</div>
</div>
</li>
</ul>
</li>


<li class="nav-button uk-padding-remove uk-margin-remove uk-hidden@m hamburger-button
uk-flex uk-flex-middle">
<a uk-icon="menu" alt="Menu" uk-toggle="target: #offcanvas-nav" class="uk-height-1-1 menu uk-padding uk-flex uk-flex-middle" ga-on="click" ga-event-category="Menu - Mobile" ga-event-label="Hamburger Button" ga-event-action="click"></a>
</li>
</ul>
</nav>
</div>
</header>
<main id="main" class="site-main">
<div class="main-alert-bar breaking-news is-active">
<div class="alert-bar">
<div class="uk-grid uk-grid-small" uk-grid>
<div class="uk-width-auto">
<div class="alert-bar-title uk-flex uk-flex-middle uk-padding-remove">
&nbsp;&nbsp;&nbsp;&nbsp;<span class="uk-icon" uk-icon="bolt"></span>&nbsp;
<span class="uk-margin-small-left uk-margin-small-right">
Breaking News </span>
</div>
</div>
<div class="uk-width-expand">
<a class="alert-bar-alert uk-width-1-1 uk-flex uk-flex-middle uk-link-reset" href="https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/" ga-on="click" ga-event-category="Alert Bar" ga-event-action="click">
<div class="alert-bar-alert-text uk-text-truncate uk-padding-small-remove uk-padding-remove-left">
Victim&#8217;s name released from Monday&#8217;s fatal Mason City structure fire </div>
</a>
</div>
</div>
</div>
</div>
<div class='adunit adunit-leaderboard uk-flex uk-flex-center' data-adunit='KGLO-NS_Leaderboard' data-size-mapping=horizontal-mapping></div>
<div class="nav-background-light main-container">
<div class="uk-section uk-section-small article">
<div class="uk-container uk-container-small">
<div class="uk-grid uk-flex post-51773 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news category-local-news" id="post-51773" uk-grid>
<div class="uk-width-1-1 uk-margin-small-bottom">
<div class="uk-grid uk-grid-small uk-grid-divider" uk-grid>
<div><a class="uk-text-uppercase text-xxsmall uk-text-bold" href="https://www.kglonews.com/category/breaking-news/" ga-on="click" ga-event-category="Post Post" ga-event-label="Category - Breaking News" ga-event-action="click">Breaking News</a></div><div><a class="uk-text-uppercase text-xxsmall uk-text-bold" href="https://www.kglonews.com/category/local-news/" ga-on="click" ga-event-category="Post Post" ga-event-label="Category - Local News" ga-event-action="click">Local News</a></div> </div>
<h1 class="article-title uk-margin-small">
Victim&#8217;s name released from Monday&#8217;s fatal Mason City structure fire	</h1>
<div class="article-byline uk-grid uk-grid-small uk-grid-divider uk-flex uk-flex-middle uk-text-meta text-xxsmall uk-padding-remove-left" uk-grid>
<div class="uk-width-auto uk-padding-right uk-padding-remove-left uk-margin-remove uk-flex uk-flex-middle uk-grid">

<div class="text-xxsmall byline-author uk-padding-remove">

<em>
<div class="byline-date uk-margin-remove uk-padding-remove">
Feb 26, 2021 @ 11:02am </div>
</em>
</div>
</div>

<div class="uk-padding-remove uk-width-expand uk-flex uk-flex-right byline-sharing">
<div>
<div class="button-group-rounded uk-flex-inline">
<a class="uk-button uk-button-primary" uk-icon="twitter" class="uk-padding-small" href="https://twitter.com/intent/tweet?text=Victim&#8217;s%20name%20released%20from%20Monday&#8217;s%20fatal%20Mason%20City%20structure%20fire&amp;url=https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/" target="_blank" ga-on="click" ga-event-category="Social" ga-event-action="click" ga-event-label="Twitter"></a>
<a class="uk-button uk-button-primary" uk-icon="facebook" class="uk-padding-small" href="https://www.facebook.com/sharer/sharer.php?u=https://www.kglonews.com/victims-name-released-from-mondays-fatal-mason-city-structure-fire/" target="_blank" ga-on="click" ga-event-category="Social" ga-event-action="click" ga-event-label="Facebook"></a>
<a class="uk-button uk-button-secondary" uk-icon="mail" class="uk-padding-small" href="/cdn-cgi/l/email-protection#4d723e382f27282e39701b242e3924206b6e757f7c7a763e687f7d232c2028687f7d3f2821282c3e2829687f7d2b3f2220687f7d002223292c346b6e757f7c7a763e687f7d2b2c392c21687f7d002c3e2223687f7d0e243934687f7d3e393f382e39383f28687f7d2b243f286b2c203d762f222934702539393d3e7762623a3a3a63262a212223283a3e632e2220623b242e3924203e60232c2028603f2821282c3e2829602b3f222060202223292c343e602b2c392c2160202c3e2223602e243934603e393f382e39383f28602b243f2862" ga-on="click" ga-event-category="Social" ga-event-action="click" ga-event-label="Email"></a>
</div>
</div>
</div>
</div>
</div>
<div class="uk-width-1-1 uk-width-expand@m uk-margin-remove-top uk-margin-large-bottom">
<div class="aspect-ratio-8-5 uk-margin-bottom ">
<img src="https://www.kglonews.com/wp-content/uploads/2018/05/mcfd-logo-640x400.jpg" alt="" />
</div>
<p><span style="font-weight: 400;">MASON CITY &#8212; Mason City fire officials have released the name of the victim of a fatal structure fire on Monday. </span></p>
<p><span style="font-weight: 400;">The Mason City Fire Department says 60-year-old Rhonda “DeeAnn” Lloyd died as a result of injuries sustained in the fire. Firefighters responded to 777 South Eisenhower #57 shortly before 9 o’clock Monday night for the report of a house fire.</span></p>
<p><span style="font-weight: 400;"> On arrival, firefighters encountered a structure that was heavily involved in fire. Fire crews remains on the scene for almost five hours to extinguish the fire as well as investigate. </span></p>
<p><span style="font-weight: 400;">The Fire Department says their investigation has determined the cause of the fire appears to be smoking materials.</span></p>
</div>
<div class="uk-width-1-1 uk-width-medium@m box-sizing-content uk-margin-small uk-margin-remove-top">
<div class="sidebar uk-grid" uk-grid>
<div class="uk-width-1-1 uk-flex uk-flex-center align-center">
<div class='adunit adunit-companion uk-flex uk-flex-center' data-adunit='KGLO-NS_Companion' data-dimensions=300x250></div>
</div>
<div class="uk-width-1-1">
</div>
<div class="uk-width-1-1 uk-margin-small">
<div id="text-4" class="uk-margin small-12 columns uk-width-1-1 widget_text"><div class="pod module-pod uk-padding-small uk-padding-remove-top uk-margin-remove uk-padding-remove"><div class="module-header"><div class="module-content-type">For the latest</div></div> <div class="textwidget"><p><a href="https://www.kglonews.com/closings/"><img loading="lazy" class="alignnone size-full wp-image-2951" src="https://www.kglonews.com/wp-content/uploads/2019/01/new-closings.jpg" alt="" width="300" height="174" /></a></p>
</div>
</div></div><div class="uk-width-1-1">
<div class="uk-card card-border-styled uk-padding-small">
<div class="uk-width-1-1 related-content uk-grid uk-child-width-1-1 uk-child-width-1-2@s uk-child-width-1-1@m uk-flex uk-align-center uk-margin-small-bottom"><div class="uk-width-1-1 text-xxsmall uk-text-uppercase uk-text-center uk-text-bold uk-text-muted uk-margin-remove uk-padding-small uk-padding-remove-top">Trending </div> <div class="related-post">
<div class="uk-grid uk-grid-small">
<div class="width-xxsmall">
<a class="aspect-ratio-1-1" href="https://www.kglonews.com/drivers-license-rules-updated-for-80-year-olds/" ga-on="click" ga-event-category="Popular Posts Widget" ga-event-label="Image 1" ga-event-action="click">
<img src="https://www.kglonews.com/wp-content/uploads/2019/10/Real-ID-copy.jpg" alt=" " />
</a>
</div>
<div class="uk-width-expand">
<h6 class="uk-margin-remove">
<a class="uk-link-heading text-weight-medium text-small text-clamp" href="https://www.kglonews.com/drivers-license-rules-updated-for-80-year-olds/" ga-on="click" ga-event-category="Popular Posts Widget" ga-event-label="Title 1" ga-event-action="click">
Driver&#039;s license rules updated for 80 year olds </a>
</h6>
</div>
</div>
</div>
<div class="related-post">
<div class="uk-grid uk-grid-small">
<div class="width-xxsmall">
<a class="aspect-ratio-1-1" href="https://www.kglonews.com/dot-makes-change-in-services-sign-policy/" ga-on="click" ga-event-category="Popular Posts Widget" ga-event-label="Image 2" ga-event-action="click">
<img src="https://www.kglonews.com/wp-content/uploads/2021/02/logo-signs-640x400.jpg" alt=" " />
</a>
</div>
<div class="uk-width-expand">
<h6 class="uk-margin-remove">
<a class="uk-link-heading text-weight-medium text-small text-clamp" href="https://www.kglonews.com/dot-makes-change-in-services-sign-policy/" ga-on="click" ga-event-category="Popular Posts Widget" ga-event-label="Title 2" ga-event-action="click">
DOT makes change in services sign policy </a>
</h6>
</div>
</div>
</div>
<div class="related-post">
<div class="uk-grid uk-grid-small">
<div class="width-xxsmall">
<a class="aspect-ratio-1-1" href="https://www.kglonews.com/two-vehicle-crash-south-of-rockwell-kills-mason-city-man/" ga-on="click" ga-event-category="Popular Posts Widget" ga-event-label="Image 3" ga-event-action="click">
<img src="https://www.kglonews.com/wp-content/uploads/2020/01/ISP.jpg" alt=" " />
</a>
</div>
<div class="uk-width-expand">
<h6 class="uk-margin-remove">
<a class="uk-link-heading text-weight-medium text-small text-clamp" href="https://www.kglonews.com/two-vehicle-crash-south-of-rockwell-kills-mason-city-man/" ga-on="click" ga-event-category="Popular Posts Widget" ga-event-label="Title 3" ga-event-action="click">
Two-vehicle crash south of Rockwell kills Mason City man </a>
</h6>
</div>
</div>
</div>
<div class="related-post">
<div class="uk-grid uk-grid-small">
<div class="width-xxsmall">
<a class="aspect-ratio-1-1" href="https://www.kglonews.com/it-may-become-a-crime-in-iowa-to-use-fake-urine-in-workplace-drug-tests/" ga-on="click" ga-event-category="Popular Posts Widget" ga-event-label="Image 4" ga-event-action="click">
<img src="https://www.kglonews.com/wp-content/uploads/2020/02/Capitol-dome-snow-2-640x400.jpg" alt=" " />
</a>
</div>
<div class="uk-width-expand">
<h6 class="uk-margin-remove">
<a class="uk-link-heading text-weight-medium text-small text-clamp" href="https://www.kglonews.com/it-may-become-a-crime-in-iowa-to-use-fake-urine-in-workplace-drug-tests/" ga-on="click" ga-event-category="Popular Posts Widget" ga-event-label="Title 4" ga-event-action="click">
It may become a crime in Iowa to use fake urine in workplace drug tests </a>
</h6>
</div>
</div>
</div>
<div class="related-post">
<div class="uk-grid uk-grid-small">
<div class="width-xxsmall">
<a class="aspect-ratio-1-1" href="https://www.kglonews.com/a-push-for-permanent-smoking-ban-in-iowa-casinos/" ga-on="click" ga-event-category="Popular Posts Widget" ga-event-label="Image 5" ga-event-action="click">
<img src="https://www.kglonews.com/wp-content/uploads/2021/02/smoking-casino.jpg" alt=" " />
</a>
</div>
<div class="uk-width-expand">
<h6 class="uk-margin-remove">
<a class="uk-link-heading text-weight-medium text-small text-clamp" href="https://www.kglonews.com/a-push-for-permanent-smoking-ban-in-iowa-casinos/" ga-on="click" ga-event-category="Popular Posts Widget" ga-event-label="Title 5" ga-event-action="click">
A push for permanent smoking ban in Iowa casinos </a>
</h6>
</div>
</div>
</div>
</div></div></div> </div>
</div>
</div>
</div>
</div>
</div>
<div class="uk-section uk-section-xsmall uk-margin-remove uk-padding-remove">
<div class="uk-container">
<div id="rcjsload_2a6669"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
				(function() {
				var revContentID = 94845;
				var referer="";try{if(referer=document.referrer,"undefined"==typeof referer||""==referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
				var rcds = document.getElementById("rcjsload_2a6669");
				var rcel = document.createElement("script");
				rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
				rcel.type = 'text/javascript';
				rcel.src = "https://trends.revcontent.com/serve.js.php?w="+revContentID+"&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+encodeURIComponent(referer);
				rcel.async = true;
				rcds.appendChild(rcel);
				})();
			</script>
</div>
</div>
</div>
<div class='adunit adunit-footer uk-flex uk-flex-center' data-adunit='KGLO-NS_Footer' data-size-mapping=horizontal-mapping></div>
</main>
<footer class="uk-section uk-section-muted">
<div class="uk-container">
<div class="uk-grid uk-grid-large uk-flex uk-flex-middle uk-flex-center uk-padding uk-padding-remove-vertical uk-margin-top uk-margin-bottom uk-padding-remove-right" uk-grid>
<div class="uk-width-1-1 uk-width-small@m uk-padding-remove uk-flex uk-flex-center uk-margin-left">
<a href="https://www.kglonews.com" ga-on="click" ga-event-category="Footer" ga-event-label="Station Logo" ga-event-action="click" class="station-logo uk-margin-small-bottom">
<img class="station-logo" src="https://dl.airtable.com/.attachments/b1bee7a3216d76a06bbcd24b19c4ceba/5f5b591b/KGLO-NEWS-LOGO-2.png" draggable="false">
</a>
</div>
<div class="uk-width-1-1 uk-width-expand@m uk-padding-remove-left uk-margin-remove-left uk-flex uk-flex-center uk-flex-left@m uk-grid-margin uk-margin-remove-top uk-margin-bottom uk-first-column">
<ul class="uk-list list-dot-divider uk-text-meta uk-text-small uk-text-center uk-text-left@m uk-width-xlarge uk-margin-left uk-margin-remove-vertical">
<li>
<a href="https://www.alphamediausa.com/careers" target="_blank" ga-on="click" ga-event-category="Footer" ga-event-action="click" ga-event-label="Careers">
Careers </a>
</li>
<li>
<a href="http://www.alphamediausa.com/brands" target="_blank" ga-on="click" ga-event-category="Footer" ga-event-action="click" ga-event-label="Stations">
Our Stations </a>
</li>
<li>
<a href="https://www.alphamediausa.com/who-we-are" target="_blank" ga-on="click" ga-event-category="Footer" ga-event-action="click" ga-event-label="About">
About Us </a>
</li>
<li>
<a href="https://www.alphamediausa.com/advertise" target="_blank" ga-event-category="Footer" ga-on="click" ga-event-label="Advertise" ga-event-action="click">
Advertise With Us </a>
</li>
<li>
<a href="/contact" ga-on="click" ga-event-category="Footer" ga-event-action="click" ga-event-label="Contact">
Contact Us </a>
</li>
<li>
<a href="/privacy-policy" ga-on="click" ga-event-category="Footer" ga-event-action="click" ga-event-label="Privacy Policy">
Privacy Policy </a>
</li>
<li>
<a href="/terms-of-use" ga-on="click" ga-event-category="Footer" ga-event-action="click" ga-event-label="Terms Of Use">
Terms Of Use </a>
</li>
<li>
<a href="https://www.alphamediausa.com/accessibility-statement" target="_blank" ga-on="click" ga-event-category="Footer" ga-event-action="click" ga-event-label="Accessibility Statement">
Accessibility Statement </a>
</li>
<li>
<a href="/category/contest-rules" ga-on="click" ga-event-category="Footer" ga-event-action="click" ga-event-label="Contest Rules">
Contest Rules </a>
</li>
<li>
<a href="https://dl.airtable.com/.attachments/908407f83176bf250c08015b66c825cb/799d3220/mason-city.pdf" target="_blank" ga-on="click" ga-event-category="Footer" ga-event-action="click" ga-event-label="EEO Report">
EEO Report </a>
</li>
<li>
<a href="https://publicfiles.fcc.gov/am-profile/kglo" target="_blank" ga-on="click" ga-event-category="Footer" ga-event-action="click" ga-event-label="Public Inspection File">
KGLO Public Inspection File </a>
<span class="uk-icon uk-text-top" uk-icon="icon: info; ratio: .75;" uk-tooltip="If you have a disability preventing you from viewing this file, please contact hr.services@alphamediausa.com">
</span>
</li>
<li>
<a href="/fcc-applications" ga-on="click" ga-event-category="Footer" ga-event-action="click" ga-event-label="FCC Applications">
FCC Applications </a>
</li>
</ul>
</div>
<div class="uk-width-1-1 uk-width-medium@m uk-text-center uk-text-right@m uk-padding-remove uk-margin-small-top">
<a class="uk-icon" href="https://www.alphamediausa.com/" target="_blank" ga-on="click" ga-event-category="Footer" ga-event-action="click" ga-event-label="AlphaMedia Logo">
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" width="194" x="0" y="0" viewBox="0 0 535.61 126.96" xml:space="preserve">
<path fill="#666766" class="st0" d="M300.18 52.61h-.17l-21.79-39.7h-5.11v57.94l-22.43-57.94h-16.59l-22.14 57.41V12.91h-14.59v22.93h-23.37V12.91H159.4V27c-2.69-8.89-10.91-14.08-23.01-14.08h-22.67v47.25H86.79V12.91H72.2v57.42L49.97 12.91h-16.6L9.92 73.72H25.3l3.65-10.08h25.28l3.65 10.08h70.43V54.78h8.08c12.1 0 20.32-5.36 23.01-14.18v33.11h14.59V49.83h23.37v23.89h28.66l3.65-10.08h25.28l3.65 10.08h19.38v-52.9h.17l20.34 37.96h3.15l20.26-37.96h.17v52.9h4.94v-60.8h-5.11l-21.72 39.69zM33.72 50.35s7.64-20.93 7.73-21.02h.26c.09.09 7.73 21.02 7.73 21.02H33.72zm103.1-8.25h-8.51V26.2h8.51c6.17 0 8.95 3.13 8.95 7.9s-2.79 8-8.95 8zm97.62 8.25s7.64-20.93 7.73-21.02h.26c.09.09 7.73 21.02 7.73 21.02h-15.72zm111.19 18.68h34.38v4.69h-39.23v-60.8h39.15v4.69h-34.3v21.72h27.06v4.78h-27.06v24.92zm64.86-56.12h-19.23v60.8h19.92c17.96 0 31.06-11.21 31.06-30.14 0-18.84-13.11-30.66-31.75-30.66zm.51 56.12h-14.89V17.6h14.21c15.4 0 26.98 9.21 26.98 25.97 0 16.86-11.75 25.46-26.3 25.46zm41.51-56.12h4.95v60.8h-4.95v-60.8zm45.35 0h-5.19l-26.04 60.8h5.19l7.57-17.81h31.57l7.57 17.81h5.28l-25.95-60.8zm-16.51 38.4s13.7-32.57 13.79-32.66h.17c.08.09 13.79 32.66 13.79 32.66h-27.75zM20.92 96.93c5.56 0 9.59 3.9 9.59 9.46 0 5.56-4.03 9.46-9.59 9.46s-9.59-3.9-9.59-9.46c-.01-5.56 4.02-9.46 9.59-9.46zm0 14.8c3.02 0 5.2-2.08 5.2-5.33 0-3.28-2.18-5.36-5.2-5.36s-5.2 2.08-5.2 5.36c0 3.25 2.18 5.33 5.2 5.33zM41.14 104.63h-.08c0 .03.05 2.26.05 4.63v6.24h-4.37V97.3h4.42l7.75 10.66H49c0-.03-.03-2.37-.03-4.34V97.3h4.37v18.2h-4.45l-7.75-10.87zM60.98 107.9v-3.56h10.58v3.56H60.98zM82.51 112.48l-1.09 3.02h-4.6l7.02-18.2h4.97l7.05 18.2h-4.68l-1.09-3.02h-7.58zm4.84-7.59c-.57-1.51-.99-2.65-1.01-2.68h-.08c-.03.03-.44 1.14-1.01 2.65l-1.3 3.64h4.71l-1.31-3.61zM101.7 97.3h4.37v18.2h-4.37V97.3zM119.35 109.49H117.4v6.01h-4.37V97.3h6.92c4.58 0 7.25 2.39 7.25 6.16 0 2.5-1.22 4.34-3.43 5.17l4.16 6.86h-5.17l-3.41-6zm.88-3.48c1.61 0 2.5-.81 2.5-2.34 0-1.51-.83-2.42-2.52-2.42h-2.81v4.76h2.83zM168.28 96.93c5.56 0 9.59 3.9 9.59 9.46 0 5.56-4.03 9.46-9.59 9.46s-9.59-3.9-9.59-9.46c0-5.56 4.03-9.46 9.59-9.46zm0 14.8c3.02 0 5.2-2.08 5.2-5.33 0-3.28-2.18-5.36-5.2-5.36s-5.2 2.08-5.2 5.36c0 3.25 2.18 5.33 5.2 5.33zM188.51 104.63h-.08c0 .03.05 2.26.05 4.63v6.24h-4.37V97.3h4.42l7.75 10.66h.08c0-.03-.03-2.37-.03-4.34V97.3h4.37v18.2h-4.45l-7.74-10.87zM208.35 107.9v-3.56h10.58v3.56h-10.58zM229.3 109.83c.36 1.38 1.64 2.18 3.61 2.18 1.66 0 2.68-.57 2.68-1.74 0-1.74-2.18-1.64-4.42-2.18-2.47-.6-5.54-1.74-5.54-5.59 0-3.72 2.81-5.56 6.89-5.56 3.72 0 6.37 1.51 7.38 4.76l-4.16 1.12c-.44-1.33-1.48-2.05-3.3-2.05-1.66 0-2.37.65-2.37 1.61 0 1.53 1.74 1.77 4.29 2.29 2.68.52 5.64 1.66 5.64 5.59 0 3.74-2.63 5.62-7.07 5.62-3.17 0-6.76-.96-7.8-4.91l4.17-1.14zM246.25 97.3h4.37v18.2h-4.37V97.3zM266.87 101.35v14.14h-4.37v-14.14h-5.56V97.3h15.5v4.06h-5.57zM278.75 97.3h13.26v4.06h-8.89v3.12h6.55v3.64h-6.55v3.33h9.02v4.06h-13.39V97.3zM331.27 96.93c5.56 0 9.59 3.9 9.59 9.46 0 5.56-4.03 9.46-9.59 9.46s-9.59-3.9-9.59-9.46c-.01-5.56 4.02-9.46 9.59-9.46zm0 14.8c3.02 0 5.2-2.08 5.2-5.33 0-3.28-2.18-5.36-5.2-5.36s-5.2 2.08-5.2 5.36c0 3.25 2.18 5.33 5.2 5.33zM351.5 104.63h-.08c0 .03.05 2.26.05 4.63v6.24h-4.37V97.3h4.42l7.75 10.66h.08c0-.03-.03-2.37-.03-4.34V97.3h4.37v18.2h-4.45l-7.74-10.87zM371.33 107.9v-3.56h10.58v3.56h-10.58zM396.63 97.3c5.43 0 9.59 3.69 9.59 9.18 0 5.51-4.19 9.02-9.57 9.02h-7.77V97.3h7.75zm-.23 14.14c2.7 0 5.43-1.38 5.43-4.97 0-3.56-2.73-5.12-5.43-5.12h-3.15v10.09h3.15zM412.46 97.3h13.26v4.06h-8.89v3.12h6.55v3.64h-6.55v3.33h9.02v4.06h-13.39V97.3zM446.42 111.05c0-4.32.05-6.45.05-6.47h-.05c-.03.03-.91 1.66-1.79 3.22l-1.77 3.2h-2.44l-1.77-3.15c-.91-1.61-1.77-3.25-1.79-3.28h-.08c0 .03.05 2.16.05 6.47v4.45h-4.37V97.3h4.63l4.58 8.14h.08l4.6-8.14h4.45v18.2h-4.37v-4.45zM462.33 112.48l-1.09 3.02h-4.6l7.02-18.2h4.97l7.05 18.2H471l-1.09-3.02h-7.58zm4.84-7.59c-.57-1.51-.99-2.65-1.01-2.68h-.08c-.03.03-.44 1.14-1.01 2.65l-1.3 3.64h4.71l-1.31-3.61zM485.91 104.63h-.08c0 .03.05 2.26.05 4.63v6.24h-4.37V97.3h4.42l7.75 10.66h.08c0-.03-.03-2.37-.03-4.34V97.3h4.37v18.2h-4.45l-7.74-10.87zM512.82 97.3c5.43 0 9.59 3.69 9.59 9.18 0 5.51-4.19 9.02-9.57 9.02h-7.77V97.3h7.75zm-.23 14.14c2.7 0 5.43-1.38 5.43-4.97 0-3.56-2.73-5.12-5.43-5.12h-3.15v10.09h3.15zM303.87 118.95l6.68-3.85-6.68-3.86zM139.94 118.95l6.67-3.85-6.67-3.86z" />
</svg>
</a>
<p class="uk-text-meta">
&copy; 2021 Alpha Media LLC.<br />All Rights Reserved. </p>
</div>
</div>
</div>
</footer>
</div>
<div id="offcanvas-nav" class="nav-background-light" uk-offcanvas="overlay: true;">
<div class="uk-offcanvas-bar">
<button class="uk-offcanvas-close" type="button" uk-close></button>
<h1 class="offcanvas-bar-title uk-text-center uk-flex uk-flex-center">
<a href="https://www.kglonews.com" ga-on="click" ga-event-category="Menu - Mobile" ga-event-label="Station Logo" ga-event-action="click" class="station-logo" uk-toggle="#offcanvas-nav">
<img id="station-logo" src="https://dl.airtable.com/.attachments/b1bee7a3216d76a06bbcd24b19c4ceba/5f5b591b/KGLO-NEWS-LOGO-2.png" draggable="false" />
</a>
</h1>
<div class="uk-text-meta uk-text-center uk-flex uk-flex-center">
Your Hometown News Station </div>
<form class="nav-search uk-search-navbar uk-search uk-width-1-1" action="https://www.kglonews.com/" method="GET">
<button type="submit" class="uk-search-icon-flip" uk-search-icon></button>
<input class="uk-search-input" type="search" name="s" placeholder="Search..." />
</form>
<div id="nav-2">
<ul class="uk-nav uk-nav-primary uk-nav-parent-icon" uk-nav><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children uk-parent menu-item-18990 offcanvas-nav-item"><a href="https://www.kglonews.com/category/local-news/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="Local News">Local News</a>
<ul class="uk-nav-sub">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25116 offcanvas-nav-item"><a href="https://www.kglonews.com/category/audio-archives/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="Audio Archives">Audio Archives</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25130 offcanvas-nav-item"><a href="https://www.kglonews.com/category/ask-the-mayor/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="Ask the Mayor">Ask the Mayor</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children uk-parent menu-item-418 offcanvas-nav-item"><a href="https://www.kglonews.com/kglo-krib-sports/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="Sports Broadcasts">Sports Broadcasts</a>
<ul class="uk-nav-sub">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-419 offcanvas-nav-item"><a href="https://www.kglonews.com/kglo-krib-sports-broadcast-calendar/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="KGLO &#038; KRIB Sports Broadcast Calendar">KGLO &#038; KRIB Sports Broadcast Calendar</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48955 offcanvas-nav-item"><a href="https://www.kglonews.com/2020-21-clear-lake-lions-winter-sports-on-krib/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="2020-21 Clear Lake Winter Sports on KRIB">2020-21 Clear Lake Winter Sports on KRIB</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47961 offcanvas-nav-item"><a href="https://www.kglonews.com/2020-21-mohawk-hockey-on-krib/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="2020-21 Mohawk Hockey on KRIB">2020-21 Mohawk Hockey on KRIB</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46119 offcanvas-nav-item"><a href="https://www.kglonews.com/2020-clear-lake-lions-football/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="2020 Clear Lake Lions Football on KRIB">2020 Clear Lake Lions Football on KRIB</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46247 offcanvas-nav-item"><a href="https://www.kglonews.com/2020-mason-city-high-football-on-am-1300-kglo/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="2020 Mason City High Football on AM-1300 KGLO">2020 Mason City High Football on AM-1300 KGLO</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46246 offcanvas-nav-item"><a href="https://www.kglonews.com/2020-newman-football-on-93-9-kia-fm/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="2020 Newman Football on 93.9 KIA-FM">2020 Newman Football on 93.9 KIA-FM</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46120 offcanvas-nav-item"><a href="https://www.kglonews.com/local-sports-broadcast-archives/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="Local Sports Broadcast Archives">Local Sports Broadcast Archives</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46893 offcanvas-nav-item"><a href="https://www.kglonews.com/watch-clear-lake-lions-sports/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="Watch Lions Sports">Watch Lions Sports</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48363 offcanvas-nav-item"><a href="https://www.kglonews.com/contact/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="Contact/Social Media">Contact/Social Media</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19488 offcanvas-nav-item"><a href="https://www.kglonews.com/closings/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="Closings">Closings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-406 offcanvas-nav-item"><a href="https://www.kglonews.com/kglo-news-team/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="News Team">News Team</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37678 offcanvas-nav-item"><a href="https://sos.iowa.gov/elections/voterreg/pollingplace/search.aspx" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="Find Your Polling Place">Find Your Polling Place</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-141 offcanvas-nav-item"><a href="https://www.kglonews.com/contact/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="Contact">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145 offcanvas-nav-item"><a href="https://www.kglonews.com/weather-forecast/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="Weather">Weather</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27506 offcanvas-nav-item"><a href="http://alphamediacares.com" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="Alpha Media Cares &#8211; Donate">Alpha Media Cares &#8211; Donate</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18989 offcanvas-nav-item"><a href="https://www.kglonews.com/category/local-sports/" ga-on="click" ga-event-category="Mobile - Menu" ga-event-action="click" ga-event-label="Local Sports">Local Sports</a></li>
</ul> </div>
<ul class="uk-nav-primary uk-margin-remove-top uk-margin-bottom" uk-nav>
</ul>
<span class="uk-margin nav-primary-social">
CONNECT WITH US </span>
<ul class="uk-nav-primary uk-margin-bottom uk-flex uk-flex-wrap uk-flex-row offcanvas-social" uk-nav>
<li>
<a class="social" href="https://www.facebook.com/kglonews" target="_blank" ga-on="click" ga-event-category="Menu - Mobile" ga-event-action="click" ga-event-label="facebook">
<span class="uk-margin-remove uk-padding-remove" uk-icon="icon: facebook"></span>
</a>
</li>
<li>
<a class="social" href="https://www.twitter.com/kglonews" target="_blank" ga-on="click" ga-event-category="Menu - Mobile" ga-event-action="click" ga-event-label="twitter">
<span class="uk-margin-remove uk-padding-remove" uk-icon="icon: twitter"></span>
</a>
</li>
<li>
<a class="social" href="https://soundcloud.com/user-637382429" target="_blank" ga-on="click" ga-event-category="Menu - Mobile" ga-event-action="click" ga-event-label="soundcloud">
<span class="uk-margin-remove uk-padding-remove" uk-icon="icon: soundcloud"></span>
</a>
</li>
</ul>
<span class="uk-margin nav-primary-social">
LISTEN TO US ON <ul class="uk-nav-primary uk-margin uk-flex uk-flex-wrap uk-flex-row offcanvas-social" uk-nav>
</ul>
</span>
</div>
</div>
<div class="adunit" data-adunit="KGLO-NS_Adhesion" data-outofpage="true"></div>
<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<style type="text/css"></style>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script type='text/javascript' defer src='https://www.kglonews.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.5' id='page-links-to-js'></script>
<script type='text/javascript' id='blacklab-scripts-js-extra'>
/* <![CDATA[ */
var localVar = {"adsEnabled":"1","dfpAccount":"253115939","rootPath":"https:\/\/www.kglonews.com\/","audioPlayerStreams":{"aac":"https:\/\/live.wostreaming.net\/direct\/alphacorporate-kgloamaac-ibc4","mp3":"https:\/\/live.wostreaming.net\/direct\/alphacorporate-kgloammp3-ibc4","provider":false,"playlistID":false},"stationPageStreams":"","timeZone":"America\/Chicago","currentTime":"2021-02-26T23:36:04+00:00","weatherAlertZones":["IAC033","IAC195","IAC189","IAC081","IAC197","IAC069","IAC023","IAC067","IAC131"],"alertsEnabled":"1","stationFormat":"News Talk","defaultSongTitle":"ON-AIR - KGLO AM 1300","defaultSongArtist":"KGLO News","defaultSongLink":"https:\/\/www.kglonews.com\/recently-played","defaultAlbumCover":"https:\/\/www.kglonews.com\/wp-content\/themes\/blacklab\/assets\/img\/audio\/default-album.jpg","defaultImage":"http:\/\/www.kglonews.com\/wp-content\/uploads\/2019\/07\/BL3-DefaultThumbnail-600x375-KGLO.jpg","playlistDefault":"No playlist data is available at this time. Please check back later.","playlistTimeHeader":"Time","playlistTitleHeader":"Song","playlistArtistHeader":"Artist","manualWeatherAlerts":[],"spanishTranslations":{"weatherDefault":" There are no active watches, warnings or advisories.","weatherAlert":"Weather Alert ","manualAlertMore":"View Alert","multipleAlerts":"Multiple weather alerts have been issued throughout your area. Click for more information.","alertsIssued":"Weather alerts have been issued for ","clickForMore":"Click for more information.","recommendedActions":"Recommended Actions"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kglonews.com/wp-content/themes/blacklab/assets/js/public/blacklab.min.js?ver=3.5.2' id='blacklab-scripts-js'></script>
<script type='text/javascript' src='https://pr.realvu.net/flip/2/c=E6LV_f=site_si=1606' id='realVu-js'></script>
<script type='text/javascript' src='https://www.kglonews.com/wp-includes/js/wp-embed.min.js?ver=5.6.1' id='wp-embed-js'></script>
<script>
        window.interdeal = {
            "sitekey": "83d0dc853b4570c43d28cc271dee662b",
            "Position": "Right",
            "Menulang": "EN",
            "domains": {
                "js": "https://cdn.equalweb.com/",
                "acc": "https://access.equalweb.com/"
            },
            "btnStyle": {
                "vPosition": [ "85%", null ],
                "scale": [ "0.6", "0.6" ],
                "icon": {
                    "type": 1,
                    "shape": "square",
                    "outline": false
                },
                "color": {
                    "main": "transparent",
                    "second": "#383fff",
                }
            }
        };
        (function(doc, head, body){
            var coreCall = doc.createElement('script');
            coreCall.src = 'https://cdn.equalweb.com/core/2.1.4/accessibility.js';
            coreCall.defer = true;
            coreCall.integrity = 'sha512-u8d8JJCpQ3N96oPNxrS5g/qXJEh6k9QbwpHTxjCR8ro/9EFiZCWVXNGckJpQHePetUg/UN6+QgF7ND6+MEX34w==';
            coreCall.crossOrigin = 'anonymous';
            coreCall.setAttribute('data-cfasync', true );
            body? body.appendChild(coreCall) : head.appendChild(coreCall);
        })(document, document.head, document.body);
    </script>
</body>
</html>
